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Hints & Tips
Scanning Checklist

You can eliminate most vectorization problems by scanning
your drawings using the checklist below.

Color, grayscale or
monochrome?

Most scanners give you the
option of scanning in color,
grayscale or monochrome.
These options have different
names depending on the make
of scanner you have.

Color
Your scanner’s color option will
normally create a raster image
with 16.7 million colors.

You should only use this option
if you are scanning a color
drawing with a view to
converting it to a color DXF file.
Do not use your scanner’s color
option if you are scanning a
black and white drawing - it is
easy to do this by accident as
most scanners default to color.

If you are scanning a color
drawing that you want to
convert to a color DXF file,
experiment with your scanner's
settings until the colors on the
raster image are as high
contrast, vibrant and saturated
as possible.

Warning: Color images can be
very large. E/A0 size drawings
scanned in color at 300 dpi will
take up about 385Mb of memory.

Grayscale
Your scanner’s grayscale option
(often called black and white

photo) will normally create an
image that contains 256 shades
of gray.

Grayscale images are not
normally suitable for raster to
vector conversion. You should
only select Grayscale  if you are
going to convert the grayscale
image to black and white after
scanning using Scan2CAD’s
Threshold functions:

• Simple Threshold - click .
• Adaptive Threshold - click .

See the Scan2CAD Help for
more information on Simple and
Adaptive Thresholds.

Warning: Grayscale images
can be very large. An E/A0 size
drawing scanned in grayscale at
300 dpi will take up about
128Mb of memory.

Monochrome
Your scanner’s monochrome
option (often called line art,
black and white drawing, 1 bit)
will create a much smaller
image that contains two colors
- black and white. This is the
option you should normally
choose.

When you scan a drawing in
monochrome your scanner or
scanning software has to make
a decision about which parts of
the drawing to set to black in
the raster image and which to
set to white.

Continued overpage ...

Some keyboard shortcuts

M Magnify at cursor
F Expand zoomed view

to Fill the screen
D Demagnify
Home Zoom Extents
R View Raster only
V View Vectors only
B View Both raster and

vectors
Shift+F Fade raster (makes

vectors easier to see)
G Turn vector Grab

Points on/off
C Turn vector Colors

on/off
Ctrl+F8 Clear vectors
Ctrl+D Measure in pixels.

Color, grayscale or
monochrome

When you open a raster file in
Scan2CAD there is a number
after the file name at the top of
the screen. This tells you what
type of raster image it is:

(2) Monochrome image
(256) Grayscale or 256 colors
(16.7M) 16.7 million colors

Don’t use JPEG or GIF!

• JPEG and GIF files from the
web are likely to be too low
resolution to vectorize well.

• Saving an image as JPEG or GIF
normally reduces its quality.

• JPEGs and GIFs are always
color and are unsuitable for
black and white drawings.

White lines on a
black background

If your image has white lines
on a  black background click 
to reverse it. Scan2CAD works
on images with black lines on a
white background.

Auto Deskew

If your image is monochrome,
you can deskew it automatically
by clicking .
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Scanning Checklist ... Continued

Filling the gray area on
the screen ...

When you select an area to
zoom into (e.g. the area
enclosed by the red rectangle
below) ...

Only the exact area you have
chosen is displayed on the
screen:

To expand the displayed area
so it fills the screen, press F
for Fill:

If you press F again, the view
will zoom out slightly so you
can see more of the image
on the screen.

If your drawing is clean and
sharp this is not normally a
problem. However if your
drawing has faint lines or a dirty
or tinted background you will
have to experiment with your
scanner’s settings until you get
a raster image where, as far as
possible, the parts of the raster
image that are supposed to  be
black are black and the parts
that are supposed to be white
are white.

If your scanner or scanning
software sets too much of the
drawing to white, it may
contain breaks and holes. Faint
parts may be lost.

If your scanner or scanning
software sets too much of the
drawing to black, text
characters may “bleed” so that
white spaces within them or
between them become filled
and speckles and dirt may
appear in the background.

Too much Too much
white black

Optimal

Rather than experiment with
your scanner settings until you
get optimal levels of black and
white you may find it easier to
scan your drawing in grayscale.
You can then use Scan2CAD’s
Threshold functions to create a
black and white image after
scanning. This will allow you to
experiment with different levels
of black and white without
having to rescan the drawing.

Resolution

It is not true that the higher
the scanner resolution, the
better the vectorization results.
For most drawings 200 or 300
dpi is adequate.

However, if a drawing is small
(e.g. a logo) or has fine detail,
you may need a higher scanner
resolution (see Using Scan2CAD
to convert logos included with
these Hints and Tips). On some
drawings you may need a lower
resolution. Ideally, aim for
scanned lines that are about 5
pixels thick.

Scanning physical items

Scanning a physical part like a
gasket or similar for profiling
can be problematic. Because
parts have a thickness they
produce shadows when you
scan them. Once in Scan2CAD
it can be hard to tell where the
part ends and the shadow
begins. Here are two suggestions
to help get around the problem.

Suggestion 1
1.Lay the part on a piece of

white paper.
2.Carefully trace around it with

a fine, sharp pen to get a
tight fitting profile.

3.Scan and vectorize the trace.

Suggestion 2
To reduce shadowing, put a
black sheet of paper or card
over the part in the scanner.
You may also want to try spray
painting the part white. When
you scan, the shadows will
simply become part of the black
background.

This will give you a reversed
image with a white part on a
black background. In Scan2CAD,
click  to switch the image so
you end up with a black part
on a white background.

Saving raster files

If you’re not scanning directly
into Scan2CAD, save scanned
drawings as BMP or, better, as
packbits, Fax Group 3 or Fax
Group 4 TIFF files. TIFF files
make more economic use of
hard disk space than BMP files.

DO NOT save your files as
multi layer/page TIFF which
Scan2CAD does not support or
as JPEG or GIF, which are color
only formats.
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Without OCR
OCR (text recognition) is
optional. Use this method if
your drawing has no text or the
text is poor quality.
1.Click  to load a BMP, TIFF

etc. raster file, or scan a
drawing using File>Acquire.
The Warning: Color Image
dialog may appear. If it does:

a)Select the second option.
b)Click OK. If a warning appears,

click Yes. You will enter the
Simple Threshold dialog.

c)Move the slider to a position
where the lines on your
image are as solid as possible
and the background is as
clean as possible.

d)Click OK.
2.Work through the Raster

Quality Checklist supplied
with these Hints and Tips.

3.Optional (recommended): Click
 (Raster Effects>Smooth).

4.Make sure you are zoomed
out by clicking .

5.Go to the Type Menu. This
contains vectorization settings.

• Choose the setting that best
describes your drawing, e.g.
Architectural or CNC Profile.

• If you drawing is a solid shape
to be outlined, choose Outline.

6.Vectorize the image by
clicking on . Any text will
be converted to short lines.

7.Save the vectors as DXF using
File > Vector > Save As.

Create a color DXF file
from a color raster image

1.Click  to load a BMP, TIFF
etc. raster file, or scan a
drawing using File>Acquire.

The Warning: Color Image
dialog appears. Select the
fourth option and click OK.

2.Go to Palette>Reduce Colors
Auto. Select a manageable
number of colors, e.g. 32.

3.Go to Palette > View/Edit
Palette and group together
similar colors:

a)Select all shades of a color
(e.g. all shades of red) - click
on the shades in the palette
(right), in the Preview
Window (left), or both. (You
may find this easier if you
select Hue in the dialog.)

b)Click .
c)Click on one of the colors you

selected in (a).
d)Click Preview Change. The

colors you selected in (a) are
changed to the color you
selected in (c).

e)Repeat (a) to (e) for all color
groups - whites, blues, etc.

f) Click OK.

4.Double click your left mouse
button to deselect any
selected colors.

You now have two options:

Option 1. This option is better
because it uses color
information while vectorizing.

5. Go to Palette > Select
Separation Colors. Click on
the colors you want to
vectorize and click OK.

6.Follow Steps 2 onwards of
Without OCR or With OCR.

Option 2. Use this if you were
unable to group the colors
cleanly in Steps 2 and 3 above.

5.Follow Steps 2 onwards of
Without OCR or With OCR but
just before you save the DXF
file go to Vector Edit>Vector
Colors to Raster Colors.

After vectorization press V to view Vectors, B to view Both
vectors and raster, Shift+F to Fade the raster, C to toggle

viewing vectors by Color or by type and G to toggle Grab Point
display at vector ends. Press Shift+F8 to clear vectors.

How to use Scan2CAD

This page assumes you are using Scan2CAD v7.5 or later and that
you have not turned off the Warning:Color Image dialog that
appears if you load an image that contains more than two colors.
If you have turned the dialog off, reinstall Scan2CAD to reactivate it.

This page outlines basic steps only. You may prefer to use Andrea’s
Real World Guide, which tells you how to handle imperfect scans
and tweak vectorization settings. You can get a copy by going to
www.softcover.com and clicking the Hints and Tips button.

Convert a black and white image

With OCR
Use this method if your drawing
has clear sharp text characters
that you want to vectorize.
Follow Steps 1 to 5 of
Without OCR. Then:
6.Scan2CAD’s text recognition

recognizes raster text when:
• The text is easily legible.
• Characters do not touch each

other or other drawing elements.
• Characters are not at

different orientations.
• Characters are in a font that

Scan2CAD can recognize.
Work through the Raster
Text Quality Checklist
supplied with these Hints and
Tips to ensure your text
meets these conditions.

7.Tell Scan2CAD what text size
to expect:

a)Go to OCR > Char Size.
b)Zoom into the biggest

character on your drawing by
placing your cursor over it
and scrolling your mouse
wheel forward or pressing the
M key several times, until you
can see the character clearly.

c)Click on a black part of the
raster text character. It
becomes enclosed in a box.

d)Click  to zoom out.

8.Vectorize ALL the drawing,
(drawing elements and text,
by clicking on .

9.Save the vectors as DXF using
File > Vector > Save As.
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Not getting the results you were expecting?

If Scan2CAD isn’t giving you the results you were expecting:

1.Work through the Raster Quality Checklist included with these Hints and Tips.
2.Work through the Raster Text Quality Checklist included with these Hints and Tips.
3.Work through the Color Checklist included with these Hints and Tips.
4.Work through the Vectorization Settings Checklist included with these Hints and Tips.

Alternatively, download and use Andrea’s Real World Guide, which tells you how to handle imperfect
scans and tweak vectorization settings. If you don’t already have a copy you can get one by going to
www.softcover.com and clicking the Hints and Tips button.

Raster Quality Checklist

The most common reason for poor vectorization
results is a poor quality raster image. Scan2CAD
can only give results as good as the raster image
you give it to vectorize. Nowhere is the saying
“Garbage In, Garbage Out” truer than in raster
to vector conversion.

Make sure that your image is suitable for
vectorization by going through the Raster Quality
Checklist below.

Do this even if your scanned image looks perfect.
Poor quality raster images often look fine when
viewed full screen - it’s not until you zoom into
them that you uncover their real horrors.

Is your image negative?
(white lines on a black background)

Negative image Positive image

Scan2CAD converts positive images (black or
colored lines on white paper). If your image is
negative you need to click  (Raster Effects >
Negate) to convert it to positive.

Is your image skew?

Skew image After deskew

If your image is slightly skew, deskew it as
follows:

• Click  (Raster Effects > Rotate > Auto
Deskew) to deskew black and white images.

• Click  (Raster Effects > Rotate > by Line)
to deskew any image.

Deskewing a very skew image can cause
significant deterioration in image quality. If your
image is very skew, the best thing to do is to
rescan your drawing taking care to get the
drawing straight on the scanner.

Is your image dirty?

If your image is very dirty, you may not be able
to clean it well enough to produce a meaningful
vectorization or cleaning it might take too long
to be worthwhile.

For example, there is no point trying to clean an
image that looks like the one below because there
are solid black dirty areas obscuring the drawing.

However if speckles and dirty areas do not
interfere with the drawing itself you will be able
to clean the image quickly and easily.

• To despeckle an image, click  (Raster
Effects > Clean > Remove Speckles).

• You can erase dirty areas using Scan2CAD’s
raster erase tools, particularly the area erase
(select   ) and the freehand erase
(select   ).

• There are often dirty areas around the edges
of raster images. You can delete these using
Raster Effects > Crop.
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Raster Quality Checklist ... continued

Now, zoom into your raster image by placing
your cursor over the image and pressing M on
your keyboard. Keep pressing M until the lines
are highly magnified. You can also zoom in by
scrolling your mouse wheel forwards.

What do you see?

Good quality lines

The lines on the left are
clean and strong and
distinct. If the lines on
your image look like this
you will be able to get good
vectorization results.

Hairy lines

If the lines on your image
have “hairs” like the top
line on the right, click 
(Raster Effects > Smooth)
to smooth them (bottom
line on the right).

Dithered lines

If the lines on your image
are dithered (made up of
black speckles like the
lines on the left), the best
thing to do is to rescan
your drawing. Experiment
with your scanner’s

settings until you get a scan with solid, continuous
lines that are not dithered (see the Scanning
Checklist included with these Hints and Tips).

If rescanning is not an option, try using 
(Raster Effects > Thicken > Pixels).

You may need to run Thicken > Pixels several
times to improve the quality of a dithered image
to the point where it can be vectorized
successfully. However, use Thicken > Pixels with
care as it can deteriorate the quality of the image
by thickening lines too much and allowing lines
that are close to each other to become joined.

Lines with holes

If the lines on your image
contain small holes you
can remove them using

 (Raster Effects >
Clean > Remove Holes).
To remove large holes use
Scan2CAD’s Flood Fill command (see the Help).

If your image has holes it may have been scanned
at too high a resolution. You may want to try
scanning your drawing again at a lower resolution.

Broken lines

If the lines on your image
are slightly broken you can
probably mend them
automatically using one of
or a combination of the
following methods:

•  (Raster Effects > Thicken > Lines).
•  (Raster Effects > Thicken > Pixels).
• Gap jumping. Before you vectorize the image:

1.Select a Type from the Type Menu.
2.Go to Type > Settings.
3.Set a Gap Jump Distance.

When you vectorize the image Scan2CAD will
jump over breaks that are smaller than the
distance you have specified, allowing it to
produce continuous vectors despite the gaps.

If the lines on your image are very broken you
will not be able to mend them automatically or
jump over the gaps using gap jumping. The only
way to mend a very broken image is to draw new
raster lines and arcs over the broken ones.

If your entire image is very broken it will take
too long to improve its quality to the point where
it can be successfully vectorized and there is
probably no point trying to vectorize it.

Merged lines

If the entities on your
raster image are merged
together the raster image
is too poor quality for
vectorization. There is
nothing you can do about

this unless the original drawing shows white space
between the entities. In this case it may be
possible to separate the entities by scanning the
drawing again at a higher resolution.

Fuzzy lines

If the lines on your raster
image are fuzzy the raster
image is too poor quality
for vectorization. There is
nothing you can do about
this except rescan the
drawing using the Scanning Checklist included
with these Hints and Tips.
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Raster Quality Checklist ... continued

Fuzziness is most common in JPEG images, so
take care not to save your image in JPEG format.

Overlaid information

The drawing on the right
contains a lot of overlaid
data.

Sadly, Scan2CAD is not
human. It doesn’t know
that it is looking at text
and a wiring schedule
overlaid on a building plan.
All it sees are black
patterns on a white background and it is not going
to be able to separate the data.

You are not going to be able to get a sensible

vectorization from an image with overlaid
information. There is nothing you can do about
this.

Low resolution lines

If shapes in your image are
defined by only a few
pixels and look jagged, as
in the image on the right,
your image is too low
resolution. This is particularly
common in logos and
drawings with fine detail.

The drawing needs to be
rescanned at a much
higher resolution - aim for lines that are about 5
pixels thick.

Raster Text Quality Checklist

Scan2CAD has a capability for converting raster text to vector text
using OCR. When you convert raster text using OCR, the vector
text is proper editable text rather than a series of uneditable lines
and arcs.

Scan2CAD’s OCR recognizes raster text where the following
conditions are met:

• The raster text is easily legible.
• The raster text characters do not touch each other.
• The raster text characters do not touch other drawing elements.
• The raster text characters are not at different orientations.
• The raster text characters are in a font that Scan2CAD can

recognize.

To ensure that your text meets these conditions, work through the
following Raster Text Quality Checklist.

First, place your cursor over a piece of text on your image.
Press M to Magnify. Press M again and again until your image is
highly magnified. Or, zoom in by scrolling your mouse wheel
forward. To zoom out again, click .

Is the text easily legible?

If you cannot read the text
easily, as in the examples
below, Scan2CAD won’t be able
to read it either.

If the text is not easily legible,
the only remedy is to start off
with a better quality raster
image.

If this is not possible, you will
have to retype the text
manually. You can either do this
in Scan2CAD (see Typing over
poor quality text included with
these Hints and Tips) or in your
CAD program after you have
imported the converted file into
it.

You may want to erase areas of
very poor quality text from the
raster image so that these areas
are not vectorized to lines and
arcs.

Are the characters
touching?

Scan2CAD cannot recognize
characters that touch other
characters, even if the
characters are only connected
by a few pixels:

If the characters touch, try
selecting OCR > Settings >
Split before doing OCR
recognition. When this option is
selected Scan2CAD will attempt
to split and identify touching
characters.

This will improve text
recognition on some raster
images, however on others it
may result in a lot of “junk
characters” being recognized.

This is because characters that
touch are often very poor
quality and are unrecognizable
even after splitting. For
example, the characters in the
example above have “bled”. Not
only has this caused them to
touch each other but it has also
filled in the “A”. This means that
the “A” is no longer typical of
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Raster Text Quality Checklist ... continued

an “A” and Scan2CAD may have
difficulty recognizing it even if
it is not touching other
characters.

You can often improve the
quality of an image that has
bled by rescanning it in
grayscale and thresholding it
(see the Scanning Checklist
included with these Hints and
Tips).

Is the text written over
other drawing elements?

If text is written over drawing
elements or is attached to
underlining or boxes as in the
examples below, Scan2CAD
won’t be able to recognize it.

Is the text at more than
one orientation?

Scan2CAD can only reliably
recognize text at one
orientation at a time.

Where text at different
orientations is physically
separate it can be recognized
using separate OCR runs.
However, where text at one
orientation is intermingled with
text at another orientation it is
virtually impossible to recognize
all the text. This typically affects
drawings with dimension text at
different angles, contour maps
and site plan drawings such as
the one below.

Can Scan2CAD recognize
the font?

By default, Scan2CAD can only
recognize text that has been
written using a standard font
such as the font below.

It may not recognize other fonts
well. It may also fail to
recognize standard fonts that
are narrower or wider than
normal or that are italicized.

If Scan2CAD’s default text
recognition cannot recognize a
font well and you have a lot of
images containing that font,
you can train Scan2CAD to
recognize the font (Pro version
only). You can do this if the font
characters are consistent and
do not touch.

For example:

Scan2CAD’s default text
recognition will recognize this
font but it will not recognize it
optimally because the font is
narrower than normal. You
could train Scan2CAD to
recognize this font well.

Scan2CAD’s default text
recognition will recognize this
font very poorly because it is
italicized and hand written.
However, because the
characters are clear and do not
touch you could train Scan2CAD
to recognize it.

Scan2CAD’s default text
recognition will recognize this
font very poorly because it is
hand written and because the
characters touch each other.
You could not train Scan2CAD
to recognize this font because
the characters touch.

Despite the fact that the quality
of this text is poor you could
train Scan2CAD to recognize it
because the characters are
consistent and do not touch
each other.

It takes a few hours to train
Scan2CAD to recognize a font
but it can significantly improve
text recognition.

Viewing vector elements

Viewing Grab Points at vector
ends is a quick way to see
vector extents.

Press G to turn Grab Points
On/Off.

To change Grab Point size go
to View > Grab Point Size.

You can see different vector
types in different colors:

Press C to turn vector Colors
On/Off.

Vector types are shown in the
following colors:

Continuous lines Red
Dash lines Black
Arrow lines Gray
Hatch lines Brown
Polylines Green
Circles Dark blue
Arcs Magenta
Bezier curves Pale blue
Text Magenta



Stuck? Questions? Email us at postmaster@softcover.com. Web: www.softcover.com

Page 8

© Softcover International Ltd 2002-2006. Scan2CAD is a registered trademark of Softcover International Ltd.

A technical explanation
By default, Scan2CAD
vectorizes every non-white
pixel it sees on a white
background. It does not
vectorize white pixels.

Sometimes a background
that looks white is slightly
non-white. Maybe it's criss-
crossed by non-white areas
leading to crazy paving
vectors, or maybe it's
completely non-white leading
to no vectors.

In a 256 color image 255 of
the colors are non-white.
Now imagine an image with
16.7 million colors where
only one is white! You can
see how easy it is to end up
with a non-white background!

The problem is particularly
likely if you are converting
JPEG files because JPEGs can
only be color.Vectorization Settings Checklist

Vectorization settings control the conversion of
raster images to vectors.The default settings that
are set when you select an option from the Type
Menu give good results on most drawings but
sometimes you may need to edit them.

If dash lines are not recognized
Make sure that Type > Settings > Object
Identification > Dash Line is selected.

Dash Line Dash Line
not selected selected

In the diagrams above vector end points are
enclosed in small squares.

If Dash Line is selected and dash and dash dot
lines are still not being identified try increasing
the maximum dash and gap lengths in Type >
Settings > Advanced.

If arrows are not recognized
Make sure that Type > Settings > Object
Identification > Arrow Line is selected.

If arrows are still not identified try increasing  the
maximum arrow head length in Type > Settings
> Advanced.

Arrows will not be recognized when the arrow tip
is touching a line that has a similar width to the
arrow head. If an arrow is recognized as a line,
you can quickly change it to an arrow as follows:

1.Click .
2.Right click.
3.Select Arrow 1 or Arrow 2 from the dialog.
4.Click on the lines you want to convert to arrows.

The arrow head will be at the end of the line
you click on.

If polylines are not recognized
Make sure that Type > Settings > Object
Identification > Polyline is selected. Alternatively,
use Vector Edit > Make Polylines to create
polylines after vectorization.

Color Checklist

Look at the number after the file name at the top of the screen. If
this number is 256 or 16.7M your image is grayscale or color,
even if it looks black and white!

If you try to vectorize a grayscale or color image there are three
likely outcomes:

The vectors look like crazy paving OR there are no vectors at all
OR there are a few horizontal and vertical lines at the image edge.

Solutions

• Use Thresholding to reduce image colors to black and white:

1.Click  to do a Simple Threshold or  to do an Adaptive
Threshold. If a Threshold Information dialog appears, click Yes
to continue.

2.Move the slider(s) to a position where the lines on your image
are as solid as possible and the background is as clean as possible.
Click the Help button in the Simple or Adaptive Threshold dialog
for more information on how to use the sliders.

• Whiten the image background:

1.Go to Palette > View/Edit Palette.
2.Click on the colors that look white so they become selected.

(To select a row of colors, click at the right hand end of the row.)
3.Click on Change To White.
4.Click on OK.

• Rescan the drawing using the Scanning Checklist included with
these Hints and Tips.
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Vectorization Settings Checklist ... continued

Deviation Factor
If the vectors do not follow the lines on the raster
image closely enough, decrease Type > Settings
> General > Deviation Factor.

Loose vectors After decreasing
Deviation Factor

If you have to decrease the Deviation Factor you
may have scanned your drawing at too low a
resolution. You may want to try rescanning it at
a higher resolution.

Corner Snap
If corners are chamfered, increase Type >
Settings > General > Corner Snap to sharpen
them. You may also need to increase Type >
Settings > Advanced > Corner Snap Angle
Tolerance.

Chamfered corner After increasing
Corner Snap

Pass-Thro Snap
If vectors do not cross neatly at untidy raster
junctions, increase Type > Settings > General >
Pass-Thro Snap.

Untidy junction After increasing
Pass-Thro Snap

Loose Ends Length
If you have a lot of loose end vectors, increase
Type > Settings > General > Loose Ends Length.

Loose end vectors After increasing
Loose Ends Length

To avoid loose end vectors, use Raster Effects >
Smooth ( ) before vectorization.

If hatch lines are not recognized
Make sure that the Hatch option corresponding
to the angle of the hatch lines you want to identify
is selected in Type > Settings > Object
Identification.

If hatch lines are still not identified, try increasing
the Hatch Line angle tolerance in Type > Settings
> Advanced.

If hatch lines are identified but the lines are not
parallel, select the angle in Type > Settings >
Angle Optimization that corresponds to the angle
of the hatch lines you want to identify.

If arcs or Bezier curves are not recognized
If arcs are not recognized make sure that Type >
Settings > Object Identification > Arc is selected.

If Bezier curves are not recognized make sure
that Type > Settings > Object Identification >
Bezier is selected.

You can choose to identify arcs or Bezier curves.

If the image is a typical architectural, mechanical
or electrical drawing containing mainly straight
lines, select arc. If the image is mainly curvy,
like a contour map, ship hull, aerofoil or freeform
artwork select Bezier. If you are vectorizing a
curvy image but your CAD or CNC program does
not support splines you can still select Bezier.
You can convert the Bezier curves to arcs or lines
on export using File > Vector > Export Options.

If circles are not recognized
If circles are not recognized make sure that Type
> Settings > Object Identification > Circle is
selected.

Line Width
If thick lines contain double vectors, increase Type
> Settings > General > Line Width.

Double vectors After increasing
Line Width

If you have to increase Line Width, the lines on
your raster image are thicker than normal. Thicker
lines have more unwanted protrusions and holes
so use Raster Effects > Smooth ( ) and Raster
Effects > Clean > Remove Holes ( ) before
vectorization. You may want to try rescanning
your drawing at a lower resolution to decrease
the line thickness.
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Vectorization Settings Checklist ... continued

Angle Optimization
If the vectors deviate slightly from their correct
angles due to variations in the raster image
beneath, select angles in Type > Settings > Angle
Optimization. For example:

Angle Optimization Angle Optimization
90/180 = off 90/180 = on

When 90/180 is on, lines within a user-specified
tolerance of 90 or 180 degrees are snapped to
90 or 180 degrees.

Angle Optimization Angle Optimization
45 = off 45 = on

When 45 is on, lines within a user-specified
tolerance of 45 degrees are snapped to 45
degrees.

If Angle Optimization does not appear to be
working, this is because Scan2CAD has chosen
not to optimize a line or lines. It may do this if
optimizing the line(s) would interfere with the
logical position of a node.

If Angle Optimization is set on an image that does
not have lines at the angles that have been
selected for Angle Optimization, gross distortion
of vectors can result:

In this case, turn Angle Optimization off.

Gap Jump Distance
If the vectors are broken at breaks in the raster
image, increase Type > Settings > General > Gap
Jump Distance.

Broken vectors After increasing Gap Jump
Distance

If there are a lot of breaks in your raster image
you may be able to jump them more effectively
if you use Raster Effects > Thicken > Lines ( )
and Raster Effects > Thicken > Pixels ( ) before
vectorization.

Connect Thro Nodes
If you want lines to pass at intersections rather
than join, select Type > Settings > General >
Connect Thro Nodes.

Lines join at Lines pass at
intersections intersections

In the diagrams above line end points are
enclosed in small squares.

Arcs, Bezier curves and Circles always continue
through intersections even if Connect Thro Nodes
is off.

Align to current grid
If you want to snap vectors to a grid, select a
grid spacing using Vector Edit > Grid Snap
Distance.

To view the grid, press Shift+I or select View >
View Grid. Note that you will only be able to see
the grid when you are zoomed in.

Select Type > Settings > General > Align to
Current Grid.

In the diagrams below the raster image and grid
lines are shown in gray and the vectors are
superimposed in black.

Vectors not Vectors snapped
snapped to a grid to a grid

In the diagrams in this Checklist the raster
image is shown in gray and the vectors are
superimposed in black.

You may also want to see Andrea’s Real
World Guide, which tells you how to improve
vectorizations by tweaking vectorization
settings. If you don’t already have a copy, you
can get one by going to www.softcover.com
and clicking the Hints and Tips button.
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3.Save the file in TIFF format. In the TIFF Options
dialog set Image Compression to None.

4.Load the TIFF file into Scan2CAD by starting
Scan2CAD and clicking . You can now
vectorize the file in the same way as any other
raster image.

Using Omiformat

Downloading and installing Omniformat

1.Go to http://www.omniformat.com/
download.html

2.Click on the Omniformat Download link and
download Omniformat (omniformat.exe) to
your hard drive.

3.In order to use Omniformat you will also have
to download its sister product PDF995 and the
PDF995 printer drivers.

To do this, click on the PDF995 Download link.
This will take you to another web page.

Download the PDF995 Printer Driver
(pdf995s.exe) and the Free Converter
(ps2pdf995.exe) to your hard drive.

4.You should now have three files on your hard
drive - omniformat.exe, pdf995s.exe and
ps2pdf995.exe.

Install them in the following order:
ps2pdf995.exe, pdf995s.exe, omniformat.exe.

Using Omniformat
Once you’ve installed Omniformat you are ready
to turn a PDF file into a raster image suitable for
Scan2CAD to convert. Do the following:

1.Load the PDF file you want to convert into
Acrobat Reader. Make a note of the file’s paper
size - it’s width and height will be displayed at
the bottom left of the Acrobat screen (you may
need to pass your mouse over the bottom left
of the screen to see the width and height).

2.Go to Start > All Programs > Software995
> Omniformat. Sponsor page messages and
sponsor pages will appear. Once you have
passed these, the Omniformat dialog appears.

3.Select BMP Microsoft Windows bitmap
image from the Output Format dropdown.

4.Click the Options button. The Options dialog
appears.

a)Select an appropriate resolution value (see A
note about resolution overpage).

Using Scan2CAD to convert PDF files to DXF

You can use Scan2CAD to convert a PDF file to
DXF by first converting the PDF file to a raster
format such as TIFF or BMP. Once it’s in raster
format, you can load it into Scan2CAD and convert
it to DXF in the normal way.

There are a number of programs available that
can convert PDF files to raster. Two - Photoshop
and Omniformat - are described here. Omniformat
is free but displays sponsor pages.

Using Photoshop

The instructions below have been written for
Photoshop CS but may also work with other
versions of Photoshop.

1.Load your PDF file into Photoshop by going to
Photoshop’s File Menu and choosing Open.

Depending on the properties of the PDF file, it
will either open straight up in Photoshop or the
Rasterize Generic PDF Format dialog will appear.

If the Rasterize Generic PDF Format dialog
appears:

• Leave the Width and Height figures at
Photoshop’s defaults.

• Set Resolution. 300 pixels/inch is good for
most line drawings, but on small drawings like
logos you may need to try a higher resolution.

• Set Mode to Grayscale.
• Switch off the Anti Aliased option.
• Click OK. The PDF file will appear in Photoshop.
• Zoom into the file and inspect it. If it is broken,

or you can’t read the text as in the examples
below, the resolution is too low. Scan2CAD will
not be able to vectorize the image well. In this
case, close the image and load it into Photoshop
again, this time choosing a higher resolution.

2.Go to Photoshop’s Image Menu > Mode. If
Bitmap is not ticked, click on it. Then:

a)Click OK to the Flatten Layers prompt.
b)A dialog called Bitmap appears.
c)Leave the Output Resolution at default.
d)Set the Method to 50% Threshold.
e)Click OK. This converts the image black and

white (2 colors).
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Using Scan2CAD to convert PDF files to DXF ... continued

You can now vectorize the BMP file in the same
way as any other raster image.

A note about resolution
Omniformat allows you to select a raster file
resolution. The correct resolution will depend on
your drawing. You may have to experiment with
different resolutions to find the best one.

When you have loaded the BMP file that
Omniformat has created into Scan2CAD, zoom
into it and take a look. If it is broken, or you
can’t read the text as in the examples below, the
resolution is too low and Scan2CAD will not be
able to vectorize the image well. In this case,
use Omniformat to create the BMP file again, this
time using a higher resolution.

A word of warning: You should be able to
convert any file up to A0/E paper size (48x36
inches or 841x1189mm) using Omniformat’s
maximum resolution of 300 dpi. If the paper size
of your PDF file is larger than this, use a lower
resolution. Attempting to create a BMP file from
a large PDF file can make a file many hundreds
of Mb in size that can choke your PC. You can tell
the paper size of your PDF file by loading it into
Acrobat Reader. The file’s width and height are
shown at the bottom left of the Acrobat screen
(you may need to pass your mouse over the
bottom left of the screen to see them).

How to scroll through an image screen by screen

3.Press the Ctrl+Right Arrow keys to move one
screen to the right.

4.Repeat Step 3 until you have moved, screen
by screen, all the way across the image.

5.Now press the Ctrl+Down Arrow keys to move
one screen down.

6.Use the Ctrl+Left Arrow keys to move one
screen to the left.

7.Keep moving to the left until you have moved
all the way across the image, then move down,
then right, then down, then left, then down,
etc., until you have moved through the entire
drawing.

Scrolling through an image one screen at a time
allows you to go through the whole image without
missing any of it. This is really useful when you’re
cleaning a raster image, tidying a vector image
or just checking results.

1.Zoom into the image so you can see enough
detail to be able to clean the image or do
whatever you need to do.

When you zoom in, the right hand part of the
screen may be gray. Press F on your keyboard
to Fill the gray part of the screen with image.

2.Use the scroll bars to move to the top left corner
of the image.

If your PDF file is smaller than A0/E size (i.e.
smaller than 48x36 inches or 841x1189 mm)
we suggest you start by trying a resolution of
300. If your PDF file is larger than A0/E we
suggest you start by trying a resolution of 72.

b)Click OK to exit the Options dialog.

5.Click the Start Monitoring button.

6.Use Windows Explorer to copy a PDF file into
the Watch Folder specified in the Omniformat
dialog. By default the Watch Folder is at
c:\program files\omniformat\watch.

VERY IMPORTANT: Omniformat will delete
the PDF file from the Watch Folder once it has
converted it so it is important that you COPY
the PDF file you want to convert into the Watch
Folder. DO NOT put the original there.

Omniformat will automatically convert the PDF
file to BMP.

(Note: You can convert several PDF files to BMP
at once by copying more than one PDF file into
the Watch Folder.)

7.Load the BMP file into Scan2CAD by starting
Scan2CAD and clicking .

Omniformat creates 256 color BMP files, so the
Warning: Color Image dialog may appear. If it
does, select the second or third option and click
OK. If the Warning: Color Image dialog does
not appear and your BMP file only contains black
and white colors you can reduce the size of the
file by decreasing its color depth. To do this,
go to Scan2CAD’s Palette Menu and choose
Reduce Color Depth > 1 Bit [Mono].
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Using Scan2CAD to convert logos

The logo is a GIF or JPEG
file designed for web use

The JPEG file below, “Jane’s
Flowers”, looks fine on the web,
because that’s what it’s been
designed for - web display.

However, if you load it into
Scan2CAD, Photoshop or any
similar program and zoom into
the “r” in the word “Flowers”
this is what you’ll see:

Looked at close up, the “r” is
not discernable even to the
human eye. It’s not surprising
that Scan2CAD has difficulties
with this type of logo.

An image with an intended end
use of web display requires
completely different attributes
from an image with an intended
end use of vectorization.
Images downloaded from the
web are generally unsuitable for
raster to vector conversion.

The logo has been scanned
at too low a resolution

Logo artwork tends to be small
and this means that we often
see logos that have been
scanned at too low a resolution.
While we recommend 200 or
300 dpi as an optimal scanning
resolution for most drawings, it
is too low if the drawing you’re
scanning is a small logo.

To illustrate the problems you’re
likely to encounter when
scanning a small logo we drew
the “Jane’s Flowers” logo so that
it measured approximately 1.6"
x 1" (4cm x 2.5cm) in size.

Below is the “r” in the word
“Flowers” after scanning the
logo at 300 dpi. You can see that
the outline of the “r” is very
jagged. This means that it is too
low resolution.

You will not be able to produce
a good vectorization from this
image:

After scanning at 1200 dpi
(below) the logo outline is much
smoother, but scanning at a
higher resolution has resulted
in a new problem.

At the higher resolution the
scanner has picked out tiny
details that are not visible to the
human eye when viewing the
logo on paper. Because the
artwork is so small, these
details are large in relation to
the size of the logo. This means
that the corners of the “r” have
become rounded and the lines
of the “r” are bumpy instead of
straight and smooth.

You will be able to produce a
usable vectorization from this
image, but the vectorization
won’t be as good as it could be
(see Getting the best
possible scan for logo
vectorization overpage).

Note that the rounded corners
of the scanned “r” have been
reflected in the vectorization by
chamfers (see overpage).

Sometimes people contact us to say they’re having difficulties
converting a logo. When they email us their problem logo we usually
find that the root of the problem is one of the following:

• The logo is a GIF or JPEG file designed for web use
• The logo has been scanned at too low a resolution

These problems are detailed here, along with the best way to get a
logo scan that will give you a good conversion.
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Using Scan2CAD to convert logos ... continued

Note that to get a good scan like
this your original artwork must
be large. You cannot start with
small original artwork and
enlarge it on a photocopier. This
will result in a scan that is no
better - and that is probably
worse - than the scan you would
get if you scanned small artwork
at a high resolution.

Once you have a smooth clean
scan you can vectorize it as
follows.

1.Go to Type > Outline.
2.Click  to vectorize the logo.

This will produce a vector image
made up of lines and Bezier
curves:

If your CAD/CNC program
doesn’t support Bezier curves
you can convert them to
polylines or arcs on export.

Alternatively, you can vectorize
the scan as follows:

1.Go to Type > Outline.
2.Go to Type > Settings.
3.Click the Object Identification

Tab, select Arc and click OK.

4.Click  to vectorize the logo.

This will produce a vector image
made up of lines and arcs.

If you can’t see any vectors
after you’ve done the
vectorization, press C on your
keyboard to display the vectors
in different colors.

If you still can’t see any vectors,
or if your vectors look
something like this ...

... it’s likely that your image is
grayscale or color, even if it
looks black and white. Do the
following:

1.Press Ctrl+F8 to delete all
vectors.

2.Go to Palette > Reduce
Colors Auto > 2. This will
turn your image into black
and white. Turning a
grayscale or color image into
black and white often gives
it ragged edges and leaves
white holes in the black
areas, so ...

3.Click  (Raster Effects >
Smooth) to smooth the
ragged edges.

4.Click  (Raster Effects >
Clean > Remove Holes) to
fill the holes.

Now repeat the vectorization.

And finally ...

Once you’ve scanned your logo,
don’t save it as JPEG as this will
almost certainly reduce the
quality of your scan. Save it as
TIFF or BMP.

To sharpen the corners, do the
vectorization again, but before
you do it go to the Type Menu,
select Settings and enter a
Corner Snap. Scan2CAD will
then remove all chamfers
shorter than the Corner Snap
and join the main lines together,
giving sharp corners:

To conclude, you will never be
able to get a really good scan
from small original artwork. This
will be reflected in the results
you can expect.

Getting the best possible
scan for logo vectorization

To get the best possible scan for
logo vectorization, start with a
bigger logo.

We drew the “Jane’s Flowers”
logo again, but this time we
drew it bigger so that it filled a
letter size / A4 sheet.

Here is the “r” in “Flowers” after
scanning the bigger logo at 300
dpi. The scanned outline is
smooth and clean:
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How to quickly edit DXF from poor quality scans

If you’ve vectorized a poor quality scan and ended up with a messy DXF file you can still use
it to quickly build up a drawing in CAD. Scan2CAD user Alan Darbyshire describes how.

“I use Scan2CAD on every
contract drafting job I do. As I
am supposed to be redrafting a
drawing from scratch my
customers expect 100% first
quality but to save myself time
I use Scan2CAD to do 80% of
the work and I do the rest, thus
ensuring that the final results
are perfect.

“The problem is that 99% of the
drawings I get are copies, not
originals. When I scan these
poor quality copies and convert
them in Scan2CAD the results
are not as good as if I was
working from the original
master drawing. Fortunately,
I’ve developed a way around
this problem which has proved
very useful when I’m redrawing
a very messy DXF file.

“Once Scan2CAD has created
the DXF file I import this into
the CAD software. In my case,
it’s AutoCAD. The method I use
is as follows. I place the
Scan2CAD DXF geometry onto

a faint colored layer that I call
‘S2C’, dark gray if it’s on a black
background. Then I create
another layer, which I call ‘Trace’
and make this white. Next, I
change all of the perfect
geometry from the ‘S2C’ layer
onto ‘Trace’. The easiest way to
do this is to just select the ‘S2C’
entities, then pick the ‘Trace’
layer. This is a standard method
of moving geometry form one
layer to another in AutoCAD.

“Very quickly I am able to build
up the detail required. Note that
I am not drawing over the ‘S2C’
layer, simply changing it to the
‘Trace’ layer. I use AutoCAD’s
Offset and Fillet Zero
commands to tidy up and
modify the Scan2CAD DXF file,
plus I am able to ‘snap’ to the
Scan2CAD geometry to add or
tidy any items as required. I
don’t have to start from a clean
sheet in CAD. It is surprising
how quickly I can build up the
detail. Afterwards, I just delete
the leftover entities on the ‘S2C’

layer using AutoCAD’s
Properties ‘Funnel’ to search for
all the ‘S2C’ entities.

“This method allows me to
complete the drawing in around
half the time it takes to redraw
it from scratch. The result is an
accurate drawing I can email to
my customer who can carry out
his amendments in turn.

“When the master drawing is
good and I scan it correctly, I
have a lot less work to do
afterwards. If you have an
architectural drawing it is of
paramount importance that you
scan it in straight as this will
affect the results you get. Yes,
you can rotate a skew drawing
in Scan2CAD but if you scan it
straight in the first place it will
save you an additional step in
the tidying-up process later on.

“Scan2CAD has saved me a lot
of time and given me a rapid
payback on my investment. It
really does help me get my work
done more quickly!”

Typing over poor quality text

When the text on your raster image is simply too poor quality to convert to vector text using
Scan2CAD’s OCR, the easiest way to convert it is to type new vector text over it.

To do this, we suggest you vectorize the drawing
in the normal way. Then, for each piece of text,
erase the unwanted vectors that have been
recognized over it and type the new vector text.
Once you’ve typed the new text, you may need
to edit it, change its size or move it. Finally,
you may want to erase the raster text beneath.

Erasing unwanted vectors

Suppose you’ve vectorized a drawing that contains
poor quality raster text:

The text will vectorize to lots of short vectors:

Before you can type new, clean vector text over
the raster text, you need to delete the unwanted
vectors. To do this:

1.Ensure the Vector Edit, Erase and Area Icons
are selected:

If they’re not, select them by clicking on them.

2.Drag a box around the area of vectors you want
to erase:
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Typing over poor quality text ... continued

It doesn’t matter that the raster text is also
enclosed within the box. As you are in Vector
Edit mode, only the vectors will be deleted.

Typing new vector text

1.Ensure the Vector Edit, Draw and Text Icons
are selected:

If they’re not, select them by clicking on them.

2.Click at the bottom left of the raster text you
want to write over:

The Vector Text Edit dialog appears. If it appears
partially over the raster text you want to write
over, drag it out of the way.

3.Type the text into the dialog.

4.Press [Enter] or click OK to exit the dialog.
The vector text you have typed appears over
the raster text:

Editing vector text

1.Ensure the Vector Edit, Draw and Text Icons
are selected:

If they’re not, select them by clicking on them.

2.Click on the text you want to edit. The Vector
Text Edit dialog appears.

3.Edit the text in the dialog.

4.Press [Enter] or click OK to exit the dialog.

Changing vector text size

1.Ensure the Vector Edit, Draw and Text Icons
are selected:

If they’re not, select them by clicking on them.

2.Click on the text you want to change the size
of. The Vector Text Edit dialog appears.

3.Edit the Height value in the dialog.

4.Press [Enter] or click OK to exit the dialog.

Moving vector text

1.Ensure the Vector Edit and Move Grab Point
Icons are selected:

If they’re not, select them by clicking on them.

2.If grab points are off, press G on your keyboard
to turn them on. Pressing G toggles grab points
on and off. If you need to make the grab points
bigger so you can see them better go to the
View Menu and choose Grab Point Size.

Grab points OFF:

Grab points ON:

The text’s grab point is the gray box at the
bottom left.

3.Position the cursor over the text’s grab point
and drag the text to its new position.

If the text doesn’t move, try increasing the Grab
Snap Distance. You can do this by pressing the
Period key on your keyboard (also marked >)
or by using Vector Edit > Grab Snap Distance.

Erasing the raster text beneath

1.Ensure the Raster Edit, Erase and Area Icons
are selected:

If they’re not, select them by clicking on them.

2.Drag a box around the raster text you want to
erase:

It doesn’t matter if your newly-typed vector
text is also enclosed within the box. As you are
in Raster Edit mode, only the raster text will
be deleted although initially it will look as
though the vector text has been deleted as well.

3.Press B on your keyboard or click on the View
Both Icon  to re-display the vector text:
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Use Scan2CAD to load raster images into AutoCAD LT!

Because AutoCAD LT’s image insert command is
disabled, you can’t load raster images into it
directly.

Scan2CAD’s Attach Raster Image option gives you
a way to load raster images into LT. See the
Scan2CAD Help for more information on the
Attach Raster Image option.

If you have Scan2CAD and AutoCAD LT, this opens
up a whole range of possibilities. For example
you can:

• View and edit the vectors in LT with the raster
underneath in a different color (Raster Overlay).

• Vectorize only the parts of a drawing you need
to change - and leave the parts you don’t need
to change in raster format.

• Load just the raster image into LT without any
vectors - and trace or draw over it in CAD.

To load the raster image into LT without vectors:

1.Load the raster image into Scan2CAD.

2.Select the Attach Raster Image option as
follows:

a)Go to File Menu > Vector > Export Options.

b)Select the Attach Raster Image option.

c)Select a raster color by entering a number into
the CAD Color Index box. Good colors to
choose for LT are:

2 (yellow)
8 (dark gray)
9 (light gray)

d)Click OK.

3.Create a blank DXF file by clicking .

4.Save the DXF file.

5.Open the DXF file in AutoCAD LT.

How to edit raster text on a scanned drawing

We’ve been in contact with a lot of users who are
using Scan2CAD as a raster editor and who are
using it to re-type and edit raster text.

Rather than using Scan2CAD’s raster text writing
tool to do this, we suggest the following.

1.Write your new or edited text using Scan2CAD’s
VECTOR text writing tool.

Writing text as vector instead of as raster gives
you the advantage of being able to easily
change the size of the text, correct any errors
you make and move the text around after you
have written it. For information on writing,
editing and moving vector text, see Typing

over poor quality text included with these
Hints and Tips.

2.After you have written all your vector text (and
deleted any raster text beneath):

a)Click  to make sure you are fully zoomed
out.

b)Press C to turn the vector text black, if it is
displayed in magenta.

c)Go to File Menu > Vector > Rasterize.

This will convert the vector text to raster.

You can also rasterize individual bits of vector
text by windowing them or zooming into them,
then choosing File Menu > Vector > Rasterize.

Outlining an object on a photo

Users sometimes send us color or grayscale
photos of objects they’d like to vectorize the
outline of. We’ve seen cows, cats, cars ...

Unfortunately, vectorizing an object on a photo
can be very difficult. This is because before you
can vectorize the object you need to divide the
photo into two discrete color areas: The object
and the background. This is usually hard to do
automatically because the object and the

background tend to share colors or shades of gray
that make it difficult or impossible to separate them.

Here’s a quick “cheat” approach:

1. Get a piece of tracing paper and trace around
the object on the photo with a pen or pencil.

2. Scan the traced outline.

3. Vectorize the outline in Scan2CAD.
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How to tell if a polyline is closed

A polyline is a series of connected line and arc
segments. Some applications - in particular CNC
- require closed polylines where the polyline start
and end points are the same and where there
are no gaps in the line and arc series. This tip
shows you how to quickly see if a polyline is closed
before you export it to another application.

When you vectorize an image using Scan2CAD
polylines are displayed in green. Lines within the
polyline are displayed in pale green and arcs
within the polyline are displayed in dark green.
(To toggle between displaying vectors by type or
by color, press C on your keyboard.)

If there are no polylines in your vectorized
drawing, you can make polylines by selecting
Vector Edit Menu > Make Polylines. If there are
still no polylines, this is either because the vectors
on your drawing are too disjointed to be joined
into polylines or because there are Bezier curves
(displayed in blue). If there are Bezier curves,
close down your vectorization by pressing Ctrl+F8.
Go to Type Menu > Settings > Object
Identification Tab and make sure that Arc and
Polyline are selected. Then revectorize the image.

Once you have a vectorization that contains
polylines you can see whether you have a closed
polyline as follows:

1.Optional: If grab points (squares at vector ends)
are displayed, turn them off by pressing G on
your keyboard.

2.Turn on polyline grab points by pressing P on
your keyboard.

Green filled squares appear at the start and end
points of polylines. There will be one green square
marking the start point of a polyline and one green
square marking the end point. If it is a closed
polyline there will be just one square marking
the start and end point of the polyline:

If there are more green squares than expected,
the polyline is broken. The breaks are at the
positions of the unexpected green squares.

To mend the polyline, you can either:

• Close down your vectorization by pressing
Ctrl+F8. Mend the raster image at the polyline
break points using Scan2CAD’s raster editing
tools. Then revectorize the image

Or

• Use Vector Edit > UnMake Polylines to break
the polylines so they can be edited. Use
Scan2CAD’s vector editing tools to mend the
breaks. Finally, use Vector Edit > Make Polylines
to re-make the polylines.

WATCH THIS SPACE FOR MORE TIPS!

Our la
test tip

s are always available on our w
eb site.

Go to www.softcover.com and click on the Hints and Tips button.


